Report on SharePoint List data using Data View Web
Part

In this screencast, I will show how you can tap into any existing
SharePoint List data and show it on any SharePoint page. In my
example, I will take three existing Lists, namely the Customers,
Orders and Order Details, to show this functionality. I will
show all three Lists connected together to create a reporting
solution.

This is a typical SharePoint Services Site. Currently, there is
only one web part that is visible that is the Windows SharePoint
Services logo. What I want to do now is to display my customer’s
data on this page. The customer’s data is represented right now
in terms of lists - I have the Customers list in the quick launch
bar here, the Orders list and the Order Details list. Let us go
ahead and take a look at each of these lists first. If I click
on Customers, here is all my customers data, Orders here is the
orders data for each customer, and Order Details has detailed
information about each order. So once again what I want to do is
on my main site, the home page of the Sales site, I am going to
display the Customers, Orders and Order Details information. So
in order to do that, what I need is a data view web part from
SharePoint Designer.

I am going to go to Start > All Programs —> Microsoft Office >
Microsoft Office SharePoint Designer 2007. Let us maximize this
window first. Now to work with any SharePoint site, the first

thing I need to do is to open that site, File - Open Site. And
now I need to put a URL of that site here. Let me grab the URL
from here, making sure that the last default.aspx should not be
in the path when I put it in the site name, so I am going to end
it with the actual site name, which is Sales, click on Open, need
to just authenticate, okay so it will open up my site.

Let me go into default.aspx page. As you know default.aspx page
is the main page of every Team Site that you create, every
SharePoint site I should say. It is loading up the Master Page
right now. Okay, so now we have our default.aspx page, which is
the main page of the site, of the Sales site, open in SharePoint
Designer. Let me go ahead and make some room so that you can see
more of SharePoint Designer, I am going to reduce the width of
these Task panes here and a little bit over here too. Alright, I
have a left web part zone and a right web part zone. The right



web part zone right is now filled with the Windows SharePoint
Services logo. I am going to take this logo out, which I am
assuming you will not need in production, so I am going to click
on it and click on Delete, so now I have two web part zones to
work with.

Also I am going to take this web part zone and move it to the
bottom, right here, just so I can get more space to work with and
let us rename the zone, double click, I am just going to rename
it Middle. The other one, I am going to rename this one Top, and
I will make one more zone and name that Bottom zone. Now to make

a zone, I will need to go to Insert > SharePoint Controls > Web
Part Zone and then double click it. Alright, so I have three
zones right now. And the reason I made three zones is because I
want to separate my web parts into each zone. Now granted you
can put multiple web parts, either horizontally or vertically
styled, you can put multiple web parts in a zone, but what I
would like to do usually is try to separate them, if possible,
for different functionalities. I will be putting my Customers
information in the Top zone, so let us go started with that. It
is tempting you right now to Click to Insert a Web Part here.
You do not want to do that, not for data view web parts. The
data view web parts, the way it works is you select a zone that
you want to put a web part in, then you go to the Data View menu,
up top here, and then click on Insert Data View. Now what that
does is it opens the Data Source Library in the Task Pane on the
right side here. Let me go ahead and take out this Apply Styles
task pane to give me more space. Okay so here is all my
information that I can put in as a Data View. There is lots of
cool stuff you can do here such as going towards a XML file,
pulling in Server-side scripts such as RSS feeds, going directly
to a Web Service, going to a Business Data Catalog connection
that you have created earlier, going directly to a Database
through here. ©Now I am not going to do any of these things here
because this screencast is geared towards showing your List data
in the site. There are other screencasts that have been created
and there are some others, which will be created, which are going
to show other functionality, but in this one I am going to stay
focused on showing the Customers, Orders, and Order Details data
in this screen.

So first I need to go to the Customers > List 2 click on this

drop down > click on this Show Data, here it is. I have all
these different fields in 92 records altogether in these fields



to display in my page here. So I am going to select the fields
that I want to display, for example CustomerID is must,
CompanyName, and I will pick City, Country, and also put I will
take the ContactName, so I will click on the ContactName, let me
re-select these things. Okay, so I have five different fields
right now selected. Now while I was selecting these, I had my
Ctrl key pushed to keep them all selected. Once I select them, I
go up here in Insert Selected Fields As and I will select the
Multiple Item View. So, it is going to take all these records
and at design time, at this time right now, going to push all the
records out to my page, here it is, in the left zone.

Alright, now I am going to go down to the Middle zone and in here
I am going to put a different web part and this web part, you
guessed it, it is going to be the Orders data. So once again

Data View > Insert Data View > going to go to Orders —> Show
Data. This time I will pick the OrderID, CustomerID, OrderDate,
ShipCity, and ShipCountry. Again I will insert them as multiple
item view. Here is my Orders data.

And lastly, I am going to go to my Bottom zone here, repeat the
steps to go to Data View = 1Insert Data View - Pick Order

Details this time - Show Data = pick the fields that I want.
These are actually going to be the fields that I already
selected. I will just take four this time actually. Once again

Insert Selected Field Items As > Multiple Item View. Okay then,
so it will put the Order Details data up on the page.

At this time I have the Customers, the Orders, and the Order
Details data appear. Let us see how this looks in the web page.
I am going to click on Save. It is warning me here and this is
saying that I am going to mark this page as a customized page.
This is a concept that came from the 2003 world as ghosting and
not ghosting. At this point, it is saying that I am unghosting
the page, which is I am marking it as a customized page. And I
am going to take this page the default.aspx page and store all of
its data and its structure and everything else in the database.
I am going to say Yes, go ahead and do that. Okay, once that is
done, let us go to the Sales site, I am going to refresh this
page, here is my data, Customers, Orders and Order Details.

Now I can paginate through this data. It is showing me first 10
records I can click on this arrow to paginate through, show me
more records, 11-20, 21-30, same thing with Orders, and the same
thing I can do with Order Details table.



Now what will be nice is to show a customer and to show only his
orders and only and then select an order from that customer’s
order and get the details only for that order. Well, all that
stuff is possible; in fact, that has been possible since the
previous version of the product, 2003, I am going to go ahead and
do that by connecting these web parts together. Let me do that
through SharePoint Designer. So going back to SharePoint

Designer - I am going to select my first web part, the Customers

web part - right click on it - click on Web Part Connections -
then I am going to say Send Row of Data To, that is correct,

click on Next > Connect to a Web Part on this page, that is also
correct. I am going to connect this Customers web part to the

Orders web part > Next.

Now, I need to make a relationship here within a column saying,
which data that appears in the Customers list is relational to
the orders data. So, I am going to make a link on the CustomerID
field. Let us see, here is my CustomerID field, and let us pick
the CustomerID field here. Okay, so the CustomerID field in both
the tables, the Customer table and the Orders table, is the one

where the connection is going to take place > Next.

Now, I need to make a hyperlink so when I click on that record in
the hyperlink in the Customers table the relational data in the
Orders table would appear. I am going to make CompanyName the

hyperlink - Next - and Finish.

Alright, as you can already see that there are hyperlinks on the
Customers field, now I am going to go to the Orders table here
and make a connection from the Orders to the Order Details. Now
before I do that, let me fix up this data. The Order 1ID,
obviously, should not be in a currency format, the way it is
showing right how. So, I am going to just click on the arrow
that appears when I hover over a record, and in the Number

Formatting Options = I will remove the 1000 separator, okay, it
looks much better. Same thing I am going to do in the Order

Details table, Number Formatting Options > Remove the 1000
separator, it looks much better now.

So, now once again, just like I did before, I am going to make a
web part connection by right clicking on the Orders web part =2

clicking Web Part Connections - and it is showing me that there
is already a connection that is coming from the Customers web
part to this web part, to the Orders web part. I do not want to



modify this one, so I am going to Add a new one > Next =

Connecting to a Web Part on this page > and that is right. Now
I am connecting from Orders to Order Details. Alright, the
relationship that I want to make is going to be on the OrderID
field, here it is OrderID, I am going to pick the OrderID in the
Orders field here in the Orders web part. Alright, once the
connection is made, click on Next, and the hyperlink that is
correct, I do want the hyperlink in the OrderID, so when I click
on that OrderID in the Orders web part, all the Order Details in

the Order Details web part should appear > Next > and Finish.

And as you can see, all these are hyperlinked too now. Now I am
going to save this page and go back to Sales page, refresh this
page, alright let me explain this error. This error is popping
up because of security time out has happened, the security
validation time out and that is a good error. There 1is no
problem with that. I am going to refresh this page and just
going to refresh the cache, and refresh everything in memory, and
this is going to show me now my first customer, which is ALFKI
CustomerID is going to take that id and show me orders only for
that customer.

Alright and it is going to take the first OrderID, which is 10643
and it is going to show me only the Order Details for that order.
If I want to change this information, I pick a different
customer. Let me go ahead and page to a new record. Let us
click on the CONSH, Consolidated Holdings, alright so I am
showing the Consolidated Holdings records. And if I click on the
10462, okay, now the Order Details are showing me Jjust that
order.

It is that easy now to use a data view web part to show the
information that is in your list and then to make a connection
from web part to web part to show certain data, filtered data.
In a separate screencast, I will show how to make this data look
even better, so how do you put formatting around this information
so to make it look more presentable, also how do you edit this
information, now this is all Read-only data, how do you edit the
information that is in your list using these web parts. I will
also show that in a different screencast, so look out for those
screencasts on SharePoint-Screencasts.com.



